installazione su xampp

3 posts / 0 new
Last post
primiano
Offline
Last seen: 2 years 8 months ago
Joined: 15/03/2017 - 12:15
installazione su xampp

salve, dopo aver installato xampp dopo aver fatto tutti i passaggi :
- creazione database con utente
-Spostare tutte le directory e i file nella cartella di root del Web server.
- ed una volta compilato i form d'installazione clicco su install.
mi compare il seguente errore:
MySQL (version 4.4+) is the only database supported at the moment.
Katak Support requires MySQL 4.4 or better! Please upgrade
come potrei risolvere?
ho installato una versione di mysql 5.5
grazie.

Tomark
Offline
Last seen: 2 months 3 weeks ago
Joined: 14/01/2013 - 16:00

Katak controlla che sia presente un database MySQL di versione superiore a 4.3. Lo fa immediatamente dopo il tentativo di connessione, usando la funzione SELECT VERSION(). Quindi sembra che la conessione sia riuscita, ma non venga riconosciuta la versione del database. Potrebbe essere che il database installato, per qualsivoglia motivo, risponde alla richiesta di versione con una stringa diversa da quelle standard che abbiamo previsto.
Se è sicuro che il database è installato correttamente, può provare a modificare il file install/setup.php togliendo semplicemente le righe 101 e 102 che effettuano il controllo:

if(!$errors && (db_version()<'4.4'))
$errors['mysql']='Katak Support requires MySQL 4.4 or better! Please upgrade';

e riprovando l'installazione.
Comunque grazie per la segnalazione: da parte nostra faremo ulteriori controlli.

Tomark
Offline
Last seen: 2 months 3 weeks ago
Joined: 14/01/2013 - 16:00

Da successivi controlli abbiamo notato che il problema potrebbe dipendere dal fatto che XAMPP in realtà installa MariaDB e non MySQL, anche se con driver compatibili. Di fatto Katak-support funziona ugualmente, ma fallisce il controllo della versione del database durante la prima fase della installazione.
Vedremo se possibile abilitare completamente anche MariaDB in una delle prossime versioni.